Difficulties access training system in the US
Incident Report for Proofpoint Security Awareness
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 11:16 EDT
Investigating
We are currently investigating this issue.
Posted Jun 24, 2022 - 10:47 EDT
This incident affected: U.S. Environment (Training Platform - U.S., PhishAlarm - CLEAR - U.S.).