Issues with accessing some administrative functions in EU.
Incident Report for Proofpoint Security Awareness
Resolved
This incident has been resolved.
Posted May 29, 2020 - 05:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 29, 2020 - 05:32 EDT
Investigating
We are currently investigating this issue.
Posted May 29, 2020 - 05:22 EDT
This incident affected: Europe Environment (Training Platform - Europe, Simulated Phishing - Europe).